Endpoint Protector Knowledge Base

Below you can explore FAQs related to Endpoint Protector and find the information you need. For any other additional questions, suggestions, and improvements please contact the support team.

What Endpoint Protector Client runs on Mac OS 10.7?

As a general rule, the Endpoint Protector Client maintains backwards compatibility. Unfortunately, for some older OSs, this is not always possible due to technology limitations. Considering also the security vulnerabilities present in old operating systems, we recommend updating to a newer version.

If however, you want to continue running Mac OS 10.7 and want to use Endpoint Protector, the Client version you are looking for is 1.5.9.6. The Client is available on request, by contacting our Support Department.
Was this article helpful?
YES NO
Can you please tell us how we can improve this article.
Thank you for your feedback!